add a crate for VAAPI-based H.264 decoding
[nihav-player.git] / hwdec-vaapi / Cargo.toml
diff --git a/hwdec-vaapi/Cargo.toml b/hwdec-vaapi/Cargo.toml
new file mode 100644 (file)
index 0000000..df79b33
--- /dev/null
@@ -0,0 +1,20 @@
+[package]
+name = "hwdec_vaapi"
+version = "0.1.0"
+authors = ["Kostya Shishkov <kostya.shishkov@gmail.com>"]
+edition = "2018"
+rust-version = "1.69"
+
+[dependencies.libva]
+package = "nihed-cros-libva"
+version = "0.0.4"
+path = "../nihed-cros-libva"
+
+[dependencies.nihav_core]
+path = "../../nihav-core"
+
+[dev-dependencies]
+nihav_commonfmt = { path = "../../nihav-commonfmt", default-features=false, features = ["all_demuxers"] }
+
+[features]
+default = []