videoplayer: add hardware-accelerated H.264 video decoding support
[nihav-player.git] / videoplayer / Cargo.toml
index f145029d15bcce3e7c9be085bc9f9f675e75634e..8cdc4a2bb96312807f13b82ff47b4bb0dd34c8eb 100644 (file)
@@ -8,9 +8,11 @@ edition = "2018"
 nihav_core = { path="../../nihav-core" }
 nihav_registry = { path="../../nihav-registry" }
 nihav_allstuff = { path="../../nihav-allstuff" }
+hwdec_vaapi = { path="../hwdec-vaapi", optional = true }
 
 sdl2 = "^0.33"
 
 [features]
-default = []
-debug = []
\ No newline at end of file
+default = ["hwaccel"]
+debug = []
+hwaccel = ["hwdec_vaapi"]
\ No newline at end of file