make tests that rely on external demuxers use only those from external crates
[nihav.git] / nihav-indeo / Cargo.toml
index 901d0e408b5d219cd246b908472ca29cba9e88fd..5b98dd17f3ad51a43c5a9212dce2398fbf58081e 100644 (file)
@@ -6,10 +6,13 @@ edition = "2018"
 
 [dependencies.nihav_core]
 path = "../nihav-core"
+
+[dependencies.nihav_codec_support]
+path = "../nihav-codec-support"
 features = ["h263", "fft", "dsp_window"]
 
 [dev-dependencies]
-nihav_commonfmt = { path = "../nihav-commonfmt" }
+nihav_commonfmt = { path = "../nihav-commonfmt", default-features=false, features = ["all_demuxers"] }
 
 [features]
 default = ["all_decoders"]