h264: introduce inline assembly for CABAC get_bit() and bump compiler version
[nihav.git] / nihav-itu / Cargo.toml
index 19eaa50965232f9cbd34cf489e313890dcc9fb96..8badb20d49d1a9c288e8b4f48521261093a9a979 100644 (file)
@@ -3,6 +3,7 @@ name = "nihav_itu"
 version = "0.1.0"
 authors = ["Kostya Shishkov <kostya.shishkov@gmail.com>"]
 edition = "2018"
+rust-version = "1.69"
 
 [dependencies.nihav_core]
 path = "../nihav-core"
@@ -14,7 +15,7 @@ path = "../nihav-codec-support"
 nihav_commonfmt = { path = "../nihav-commonfmt", default-features=false, features = ["all_demuxers"] }
 
 [features]
-default = ["all_decoders"]
+default = ["all_decoders", "simd"]
 simd = [] #enable when the default rustc is >=1.62
 
 all_decoders = ["all_video_decoders"]