add nihav-misc crate and Aware MotionWavelets decoder in it
[nihav.git] / nihav-misc / Cargo.toml
diff --git a/nihav-misc/Cargo.toml b/nihav-misc/Cargo.toml
new file mode 100644 (file)
index 0000000..faca21b
--- /dev/null
@@ -0,0 +1,25 @@
+[package]
+name = "nihav_misc"
+version = "0.1.0"
+authors = ["Kostya Shishkov <kostya.shishkov@gmail.com>"]
+edition = "2018"
+
+[dependencies.nihav_core]
+path = "../nihav-core"
+
+[dependencies.nihav_codec_support]
+path = "../nihav-codec-support"
+
+[dev-dependencies]
+nihav_commonfmt = { path = "../nihav-commonfmt", default-features=false, features = ["all_demuxers"] }
+
+[features]
+default = ["all_decoders"]
+decoders = []
+
+all_decoders = ["all_video_decoders", "all_audio_decoders"]
+
+all_video_decoders = ["decoder_mwv1"]
+decoder_mwv1 = ["decoders"]
+
+all_audio_decoders = []